[Discourse.ros.org] [General] Lunar to target Gazebo 7

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[Discourse.ros.org] [General] Lunar to target Gazebo 7

Saurabh Bansal via ros-users


Hi ROS users!

Recent Lunar testing unveiled that Gazebo7 and Gazebo8 won't by side by side installable. We will thus have a last minute change and ROS Lunar will target Gazebo 7 (that is available upstream for all supported platforms). The matching amendment to REP3 is available [here](https://github.com/ros-infrastructure/rep/pull/131).

Note that you can use newer versions of gazebo (e.g 7.7) if you have packages.osrfoundation.org in your sources. All Gazebo 7.X are ABI compatible and the potential for regression from one version to the next is very low.

Finally, you will be able to install gazebo 8 with ROS Lunar and gazebo-ros-pkgs will support it but this will not be the default version used to build packages on the buildfarm.

Sorry for the late notice,

PS: if you would like packages on the ROS buildfarm to use the latest gazebo7 rather than the upstream one one feel free to comment on this thread.





---
[Visit Topic](https://discourse.ros.org/t/lunar-to-target-gazebo-7/1840/1) or reply to this email to respond.


If you do not want to receive messages from ros-users please use the unsubscribe link below. If you use the one above, you will stop all of ros-users from receiving updates.
______________________________________________________________________________
ros-users mailing list
[hidden email]
http://lists.ros.org/mailman/listinfo/ros-users
Unsubscribe: <http://lists.ros.org/mailman//options/ros-users>