[Discourse.ros.org] [General] Suspension of Debian packaging for EOL Ubuntu Yakkety

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[Discourse.ros.org] [General] Suspension of Debian packaging for EOL Ubuntu Yakkety

Dirk Thomas via ros-users


Hi ROS users!

Since we have support to [turn off EOL distros](https://discourse.ros.org/t/suspension-of-debian-packaging-for-eold-distros-saucy-utopic-vivid-and-wily/1601) on the buildfarm, we announced that we will disable distros soon after they become EOL.
Ubuntu Yakkety (16.10) has been EOL since July, and we are considering turning it off after the [upcoming Lunar sync](https://discourse.ros.org/t/preparing-for-lunar-sync-2017-08-07/2398). This will allow the buildfarm to run faster and the maintainer-ship workload to be reduced for maintainers releasing in Lunar.

As a result, we will build Lunar binaries for:

- Ubuntu Xenial and Zesty
- Debian Stretch

Please comment here if you have any feedback !





---
[Visit Topic](https://discourse.ros.org/t/suspension-of-debian-packaging-for-eol-ubuntu-yakkety/2444/1) or reply to this email to respond.


If you do not want to receive messages from ros-users please use the unsubscribe link below. If you use the one above, you will stop all of ros-users from receiving updates.
______________________________________________________________________________
ros-users mailing list
[hidden email]
http://lists.ros.org/mailman/listinfo/ros-users
Unsubscribe: <http://lists.ros.org/mailman//options/ros-users>
Reply | Threaded
Open this post in threaded view
|

[Discourse.ros.org] [General] Suspension of Debian packaging for EOL Ubuntu Yakkety

Dirk Thomas via ros-users


All Yakkety jobs have been disabled today.

What this means for you as a user:

- The packages will continue to be available from the repository however we will no longer be buidling new versions when releases are made.
- If you are on an EOL'd distro, it's strongly recommended to upgrade. (We will no longer ship updates, and you are no longer getting security updates in general.)

What this means for you as a maintainer:

- You no longer need to support the EOL'd Ubuntu distros in future releases, so the low water mark is relaxed.

- As of today, ROS Lunar is only targeting:
  - Ubuntu Xenial (16.04) and Zesty (17.04)
  - Debian Stretch (9)





---
[Visit Topic](https://discourse.ros.org/t/suspension-of-debian-packaging-for-eol-ubuntu-yakkety/2444/2) or reply to this email to respond.


If you do not want to receive messages from ros-users please use the unsubscribe link below. If you use the one above, you will stop all of ros-users from receiving updates.
______________________________________________________________________________
ros-users mailing list
[hidden email]
http://lists.ros.org/mailman/listinfo/ros-users
Unsubscribe: <http://lists.ros.org/mailman//options/ros-users>