[Discourse.ros.org] [TurtleBot] [TB3] Defectuous IMU?

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

[Discourse.ros.org] [TurtleBot] [TB3] Defectuous IMU?

Tully Foote via ros-users


Hello,

I am working on turtlebot Buger and Waffle, but I get curious values from IMU.
Linear acceleration on z axis in not equal to ~9.8 m/s. And when the robot is static, I have non zeros values on x and y axis.
I have those strange values on both Burger and Waffle robots. Curiously IMU on Waffle was working fine last week.

Some idea ?

Matt

> header:
>   seq: 592
>   stamp:
>     secs: 1515485911
>     nsecs: 742161933
>   frame_id: imu_link
> orientation:
>   x: 0.0163628198206
>   y: -0.00983170140535
>   z: 0.324311375618
>   w: 0.945753157139
> orientation_covariance: [0.0024999999441206455, 0.0, 0.0, 0.0, 0.0024999999441206455, 0.0, 0.0, 0.0, 0.0024999999441206455]
> angular_velocity:
>   x: 0.0
>   y: 0.0
>   z: 0.0
> angular_velocity_covariance: [0.019999999552965164, 0.0, 0.0, 0.0, 0.019999999552965164, 0.0, 0.0, 0.0, 0.019999999552965164]
> linear_acceleration:
>   x: 526.0
>   y: 420.0
>   z: 17362.0
> linear_acceleration_covariance: [0.03999999910593033, 0.0, 0.0, 0.0, 0.03999999910593033, 0.0, 0.0, 0.0, 0.03999999910593033]
> ---





---
[Visit Topic](https://discourse.ros.org/t/tb3-defectuous-imu/3631/1) or reply to this email to respond.


If you do not want to receive messages from ros-users please use the unsubscribe link below. If you use the one above, you will stop all of ros-users from receiving updates.
______________________________________________________________________________
ros-users mailing list
[hidden email]
http://lists.ros.org/mailman/listinfo/ros-users
Unsubscribe: <http://lists.ros.org/mailman//options/ros-users>
Reply | Threaded
Open this post in threaded view
|

[Discourse.ros.org] [TurtleBot] [TB3] Curious IMU values?

Tully Foote via ros-users


It seems that  linear acceleration units are mm/s. So ~400 and ~500 would represent noise
I have compared opencr IMU and Myahrs IMU, results are below.

So, I suppose that x and y linear acceleration are fine except on z axis. It is a calibration problem ?

![Screenshot from 2018-01-09 13-00-15|690x241](upload://4H9zS0OMUMGGLMzIBOhrWoK5y57.png)





---
[Visit Topic](https://discourse.ros.org/t/tb3-curious-imu-values/3631/2) or reply to this email to respond.


If you do not want to receive messages from ros-users please use the unsubscribe link below. If you use the one above, you will stop all of ros-users from receiving updates.
______________________________________________________________________________
ros-users mailing list
[hidden email]
http://lists.ros.org/mailman/listinfo/ros-users
Unsubscribe: <http://lists.ros.org/mailman//options/ros-users>
Reply | Threaded
Open this post in threaded view
|

[Discourse.ros.org] [TurtleBot] [TB3] Curious IMU values?

Tully Foote via ros-users
In reply to this post by Tully Foote via ros-users


[quote="MattMgn, post:2, topic:3631"]
It seems that  linear acceleration units are mm/s.
[/quote]

Not quite... There was a bit more to it than that. The original OpenCR code doesn't convert from the raw values. That was fixed in [this PR](https://github.com/ROBOTIS-GIT/OpenCR/pull/45).

That fix and others are present on the [features-from-openrobotics](https://github.com/ROBOTIS-GIT/OpenCR/tree/features-from-openrobotics) branch on the OpenCR repo. If you checkout those changes and flash the image, then your IMU values will be correct.





---
[Visit Topic](https://discourse.ros.org/t/tb3-curious-imu-values/3631/3) or reply to this email to respond.


If you do not want to receive messages from ros-users please use the unsubscribe link below. If you use the one above, you will stop all of ros-users from receiving updates.
______________________________________________________________________________
ros-users mailing list
[hidden email]
http://lists.ros.org/mailman/listinfo/ros-users
Unsubscribe: <http://lists.ros.org/mailman//options/ros-users>
Reply | Threaded
Open this post in threaded view
|

[Discourse.ros.org] [TurtleBot] [TB3] Curious IMU values?

Tully Foote via ros-users
In reply to this post by Tully Foote via ros-users


Ok, thank you for those explanation and also for your contribution

Matt





---
[Visit Topic](https://discourse.ros.org/t/tb3-curious-imu-values/3631/4) or reply to this email to respond.


If you do not want to receive messages from ros-users please use the unsubscribe link below. If you use the one above, you will stop all of ros-users from receiving updates.
______________________________________________________________________________
ros-users mailing list
[hidden email]
http://lists.ros.org/mailman/listinfo/ros-users
Unsubscribe: <http://lists.ros.org/mailman//options/ros-users>