[Discourse.ros.org] [general] REP3 proposal for Lunar Loggerhead

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

[Discourse.ros.org] [general] REP3 proposal for Lunar Loggerhead

derlcn via ros-users



I have a couple of questions about the mention of Fedora in the REP:

First, what does "recommended support" for Fedora and Debian mean?  That the build-from-source process should generally work?  Or is there thought of adding binary releases for those distributions?

Second, unless something in Fedora land changes, Fedora 25 will go EOL ~13 months after its release date[1], or around December 2017.  Fedora 26, which will be released in the June 2017 timeframe[2], will be EOL around July 2018.  Does it make sense to call out specific distribution versions when they won't all be supported over the same timeframe as the ROS release?  Or, in cases where a distributions future plans are unknown that far out, does it make more sense to just make a blanket statement that the earliest and/or latest supported version of that distribution should be supported by ROS?

That said, Fedora is already incompatible with the "Exact or Series" requirements.  We've already got pcl-1.8 in fedora 24 and higher[3], and Qt 5.6 or higher in fedora 24 and higher[4].  On the other hand, we won't introduce gazebo 8 or probably opencv-3.2 until fedora 26, as large breaking changes in released fedora versions violate the stable release updates policy[5].  So do they really need to be exact, or are they only enumerating the requirements as dictated by the environments on the "Required Support for" platforms?

[1] https://fedoraproject.org/wiki/Fedora_Release_Life_Cycle#Maintenance_Schedule
[2] https://fedoraproject.org/wiki/Releases/26/Schedule
[3] https://apps.fedoraproject.org/packages/pcl
[4] https://apps.fedoraproject.org/packages/qt5
[5] https://fedoraproject.org/wiki/Updates_Policy#Stable_Releases






---
[Visit Topic](https://discourse.ros.org/t/rep3-proposal-for-lunar-loggerhead/1179/5) or reply to this email to respond.


If you do not want to receive messages from ros-users please use the unsubscribe link below. If you use the one above, you will stop all of ros-users from receiving updates.
______________________________________________________________________________
ros-users mailing list
[hidden email]
http://lists.ros.org/mailman/listinfo/ros-users
Unsubscribe: <http://lists.ros.org/mailman//options/ros-users>
Reply | Threaded
Open this post in threaded view
|

[Discourse.ros.org] [general] REP3 proposal for Lunar Loggerhead

derlcn via ros-users



[quote="rmattes, post:5, topic:1179"]
First, what does "recommended support" for Fedora and Debian mean?  That the build-from-source process should generally work?  Or is there thought of adding binary releases for those distributions?
[/quote]

This means that we will do a best effort to support users on these platforms but not block if something is not available. It's expected that building from source should be possible on those platforms. We generate the build metadata automatically for them (aka bloom-release is aware of them and turns them on by default) And we have enabled builds on Debian already in Kinetic and since it's so close to Ubuntu there's very little difference. If there's interest from contributors to get Fedora binary builds working we would be interested in supporting bringing RPM builds online too.

[quote="rmattes, post:5, topic:1179"]
Second, unless something in Fedora land changes, Fedora 25 will go EOL ~13 months after its release date[1], or around December 2017.  Fedora 26, which will be released in the June 2017 timeframe[2], will be EOL around July 2018.  Does it make sense to call out specific distribution versions when they won't all be supported over the same timeframe as the ROS release?  Or, in cases where a distributions future plans are unknown that far out, does it make more sense to just make a blanket statement that the earliest and/or latest supported version of that distribution should be supported by ROS?
[/quote]

The timing is unfortunate. The primary reason for calling out a specific version is that for our tooling, like bloom we have to pick specific versions for which to generate metadata. We can only support available releases since the dependencies need to be known. Our release is synchronized with the Ubuntu alpha cycle so that we can use their prerelease versions for development and extend our life cycle as far as possible. They have even shorter cycles than Fedora (9 months for non-LTS)

In the past we've tried adding platforms to ROS distros and that is as much work as creating a new rosdistro, and actually harder since you are not in a tick-tock cycle so deprecations upstream can box you into a corner. So we can't plan to add 26 after our release. And the 26 Alpha looks like it won't be available until mid march. ([Fedora 26 Release Schedule](https://fedoraproject.org/wiki/Releases/26/Schedule) )


[quote="rmattes, post:5, topic:1179"]
That said, Fedora is already incompatible with the "Exact or Series" requirements.  We've already got pcl-1.8 in fedora 24 and higher[3], and Qt 5.6 or higher in fedora 24 and higher[4].  On the other hand, we won't introduce gazebo 8 or probably opencv-3.2 until fedora 26, as large breaking changes in released fedora versions violate the stable release updates policy[5].  So do they really need to be exact, or are they only enumerating the requirements as dictated by the environments on the "Required Support for" platforms?
[/quote]

It would be good to know what these will be and call them out. The goal is to have a consistent set of core dependencies that maintainers don't need to worry about supporting multiple dependencies with `#ifdef`s or other mechanisms.

A few specifics.

- PCL on Yakkety and Zesty is already 1.8 as well. We should specify that's more flexible.
- Our target of Gazebo 8 is to synchronize the Ubuntu LTS, with the ROS LTS, with the Gazebo LTS versions. To make this happen we will have to custom package Gazebo8 for the non-LTS ROS releases. And for the LTS releases we will have to at least package for the non-LTS ubuntu versions assuming the the Gazebo LTS is submitted successfully upstream. Though if we're already building the non-LTS Ubuntu version for the ROS/Gazebo LTS coverage we might as well build new packages for the Ubuntu LTS in case of a patch release to get it out quicker and more consistently. So for Fedora I think it would be best if we packaged Gazebo 8 for Fedora 25 as well. @jrivero Do we already have rpm packaging of gazebo supported?

@rmattes Could you go line by line through the dependencies and start a thread on that line of the PR if there's a discrepancy that needs to be resolved?






---
[Visit Topic](https://discourse.ros.org/t/rep3-proposal-for-lunar-loggerhead/1179/6) or reply to this email to respond.


If you do not want to receive messages from ros-users please use the unsubscribe link below. If you use the one above, you will stop all of ros-users from receiving updates.
______________________________________________________________________________
ros-users mailing list
[hidden email]
http://lists.ros.org/mailman/listinfo/ros-users
Unsubscribe: <http://lists.ros.org/mailman//options/ros-users>
Reply | Threaded
Open this post in threaded view
|

[Discourse.ros.org] [general] REP3 proposal for Lunar Loggerhead

derlcn via ros-users



[quote="tfoote, post:6, topic:1179"]
So we can't plan to add 26 after our release. And the 26 Alpha looks like it won't be available until mid march.
[/quote]

As long as the package names are "known" (which I would expect to be the case in February when they do the rebuild) we should be able to support Fedora 26.

I would even think that it might be a good idea to only support Fedora 26 then since some packages are lower then our currently planned requirements in Fedora 25. A higher version should usually not be a big problem since maintainers commonly try to keep their software compatible with newer releases (the same happens all the time on e.g. Gentoo).






---
[Visit Topic](https://discourse.ros.org/t/rep3-proposal-for-lunar-loggerhead/1179/7) or reply to this email to respond.


If you do not want to receive messages from ros-users please use the unsubscribe link below. If you use the one above, you will stop all of ros-users from receiving updates.
______________________________________________________________________________
ros-users mailing list
[hidden email]
http://lists.ros.org/mailman/listinfo/ros-users
Unsubscribe: <http://lists.ros.org/mailman//options/ros-users>
Reply | Threaded
Open this post in threaded view
|

[Discourse.ros.org] [General] REP3 proposal for Lunar Loggerhead

derlcn via ros-users
In reply to this post by derlcn via ros-users



At this point, the only discrepancies for Fedora 25 are Gazebo 7 and OpenCV 3.1.  Qt 5 versions are usually backwards compatible, so packages targeting Qt 5.3 will probably be fine forh the 5.6 or 5.7 versions in Fedora.

There's not likely to be any package name changes between f25 and f26, so things like rosdep keys should still work normally.  It would likely be safe to target f26 with the buildsystem metadata even before it's released.  Fedora 26 will officially start to "exist" at the end of February when it's branched from rawhide - at that point, there will be f26 repositories, mock configurations, buildsystem configurations, container images, etc., making it possible to build against it in a pre-alpha state.

I will note that Fedora has a system called copr, which is similar to Ubuntu PPAs.  I set up a [gazebo-latest](https://copr.fedorainfracloud.org/coprs/g/robotics-sig/gazebo-latest/) copr some time ago, to keep the latest version of Gazebo available in Fedora releases.  I kind of let it slip for a while, but I am planning on building gazebo 8 in the copr for all released Fedora versions.  It may be easier to point users to that repository than to package it separately.






---
[Visit Topic](https://discourse.ros.org/t/rep3-proposal-for-lunar-loggerhead/1179/12) or reply to this email to respond.


If you do not want to receive messages from ros-users please use the unsubscribe link below. If you use the one above, you will stop all of ros-users from receiving updates.
______________________________________________________________________________
ros-users mailing list
[hidden email]
http://lists.ros.org/mailman/listinfo/ros-users
Unsubscribe: <http://lists.ros.org/mailman//options/ros-users>
Reply | Threaded
Open this post in threaded view
|

[Discourse.ros.org] [General] REP3 proposal for Lunar Loggerhead

derlcn via ros-users



[quote="rmattes, post:12, topic:1179"]
There's not likely to be any package name changes between f25 and f26, so things like rosdep keys should still work normally.  It would likely be safe to target f26 with the buildsystem metadata even before it's released.  Fedora 26 will officially start to "exist" at the end of February when it's branched from rawhide - at that point, there will be f26 repositories, mock configurations, buildsystem configurations, container images, etc., making it possible to build against it in a pre-alpha state.
[/quote]

If things will be stabilized by February and we don't expect any changes leading up to that then it sounds like supporting 26 would be fine. I thought that it might be later in the the release cycle.

[quote="rmattes, post:12, topic:1179"]
I will note that Fedora has a system called copr, which is similar to Ubuntu PPAs.  I set up a gazebo-latest copr some time ago, to keep the latest version of Gazebo available in Fedora releases.  I kind of let it slip for a while, but I am planning on building gazebo 8 in the copr for all released Fedora versions.  It may be easier to point users to that repository than to package it separately.
[/quote]

If we do need to start building packages we will also want to setup a standard repository for rpms on the ros.org domain like we have for debian family packages. Presumably we can import from resources like the copr repos.






---
[Visit Topic](https://discourse.ros.org/t/rep3-proposal-for-lunar-loggerhead/1179/13) or reply to this email to respond.


If you do not want to receive messages from ros-users please use the unsubscribe link below. If you use the one above, you will stop all of ros-users from receiving updates.
______________________________________________________________________________
ros-users mailing list
[hidden email]
http://lists.ros.org/mailman/listinfo/ros-users
Unsubscribe: <http://lists.ros.org/mailman//options/ros-users>
Reply | Threaded
Open this post in threaded view
|

[Discourse.ros.org] [General] REP3 proposal for Lunar Loggerhead

derlcn via ros-users



It appears that OpenCV3.2 is very close to OpenCV3.1 and should be backward compatible (based on @vrabaud [comment](https://github.com/ros-infrastructure/rep/pull/123#discussion_r96831745) )?
So I'm going to move ahead and change the REP to target f26. We can revisit end of February if anything comes up.






---
[Visit Topic](https://discourse.ros.org/t/rep3-proposal-for-lunar-loggerhead/1179/14) or reply to this email to respond.


If you do not want to receive messages from ros-users please use the unsubscribe link below. If you use the one above, you will stop all of ros-users from receiving updates.
______________________________________________________________________________
ros-users mailing list
[hidden email]
http://lists.ros.org/mailman/listinfo/ros-users
Unsubscribe: <http://lists.ros.org/mailman//options/ros-users>